Article ID: 915624 - Last Review: May 16, 2007 - Revision: 2.0
Error message when you try to import a CSV file of domain members into Groove Enterprise Management Server: "File format is invalid"
SYMPTOMS
When you try to import a comma separated value (CSV) file of
users into a Groove domain in Microsoft Office Groove Server Manager 2007 or in Groove Enterprise Management Server, you may receive the
following error message:
File format is
invalid.
CAUSE
This issue occurs if the domain manager cannot read the file format, or if a field contains a comma character (,). For example, this issue occurs if "Jane Dow, PhD" appears in the Name field. A field cannot contain a comma because the comma is used to separate fields
in a CSV file.
RESOLUTION
To resolve this issue in Groove Server Manager 2007 or in Groove Enterprise Management Server 3.1, use quotation marks (") to enclose any field that contains a comma. Then, save the file in the correct format.
To resolve this issue in earlier versions of Groove Enterprise Management Server, remove any commas that appear in fields. Then, save the file in the correct format.
To resolve this issue in earlier versions of Groove Enterprise Management Server, remove any commas that appear in fields. Then, save the file in the correct format.
MORE INFORMATION
If you create the CSV file by using the template that is included with the server, this issue occurs only if a field contains a comma or another invalid character.
If you create the CSV file by using another method, this issue may occur for other reasons. For example, you may receive the error message in the following situations:
In some versions of Groove Enterprise Management Server, each line of the file must end in a comma and a carriage return. Excel does not add a comma to the end of the lines of a CSV file. Therefore, if you create the file in Excel, add an additional field to each line, but leave the field empty. Alternatively, open the exported CSV file by using a text editor, and then add a comma to the end of each line before you import the file.
For more information about how to import CSV files, click the following article number to view the article in the Microsoft Knowledge Base:
If you create the CSV file by using another method, this issue may occur for other reasons. For example, you may receive the error message in the following situations:
- You export a file from a Microsoft Windows 2000 Active Directory server as Unicode text. To resolve this issue, export the file as Text instead.
- You save a file from Microsoft Excel as Excel CSV, and then you try to import it in Groove Enterprise Management Server 3.1 or in an earlier version of the management server. To resolve this issue, save the file as CSV (MS-DOS) instead.
In some versions of Groove Enterprise Management Server, each line of the file must end in a comma and a carriage return. Excel does not add a comma to the end of the lines of a CSV file. Therefore, if you create the file in Excel, add an additional field to each line, but leave the field empty. Alternatively, open the exported CSV file by using a text editor, and then add a comma to the end of each line before you import the file.
For more information about how to import CSV files, click the following article number to view the article in the Microsoft Knowledge Base:
914694
(http://support.microsoft.com/kb/914694/
)
The last column of a CSV file may be lost when you import it into Groove Enterprise Management Server
Note: This article is from Microsoft Knowledage Base
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